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Building on a strong foundation of integrated tools and workflows for professional 
document production, InDesign CS5 lets you bring your documents to life with pages that 
include interactivity, motion, video, and sound, without sacrificing control over typography 
or design.

Focus on your layout and deliver engaging documents to a wide range of media and devices with the 
powerful features in InDesign CS5 software. Built-in creative tools and an intuitive design environment 
let you create stunning page layouts faster and more efficiently, allowing you to deliver a broad range of 
documents for print, online, and mobile devices. New collaboration tools, production features, and 
interactive abilities help you to complete the most complex projects quickly and accurately and to 
connect your audience to your projects in innovative and memorable ways.

Enjoy streamlined collaboration with colleagues and clients with InDesign CS5. Now you can track text 
changes in InDesign documents, making it much easier for you to identify and manage editorial changes 
in the layout. With CS Review, a new Adobe CS Live online service*, you can incorporate reviews directly 
into your design process, eliminating the need to keep track of email attachments or proofing-round 
printouts. As you work with InDesign CS5, you’ll find that you can do more in less time, due to a slew of 
production-boosting formatting tools and techniques. New on-object controls speed up frame- and 
frame-content editing, so you don’t have to switch tools to do common tasks. Take advantage of new 
paragraph-formatting commands that let you create headlines that span multiple columns in the same 
frame as the body text. Complete your page layout in fewer steps with productivity features that include 
combining pages with different sizes in a single InDesign file and managing page elements with an 
all-new Layers panel. InDesign CS5 lets you engage and inform your readers by integrating rich 
interactive media into any InDesign document. You can include interactivity, animation, video, and sound 
directly inside the layout file, and then preview how it will appear in the final SWF or PDF file without 
leaving InDesign. 

This Reviewer’s Guide provides a hands-on tour of the most important and powerful new features and 
enhancements in Adobe InDesign CS5. Here is an overview:

Design and layout
Part 1: Access project assets easily through the Mini Bridge panel—Bring the power of Adobe Bridge 
CS5 directly into InDesign with the new integrated Mini Bridge panel, giving you quick access to your 
Bridge Favorites and image previews without leaving InDesign. (Page 3)

Part 2: Streamline object selection and editing—Explore convenient new ways to select and edit 
frames, frame content, and even frame corners. (Page 5)

Part 3: Add image information automatically with Live Captions—Easily create dynamic captions from 
a file’s metadata. (Page 10)
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Part 4: Combine different page sizes in one document—Streamline production by including 
gatefolds, smaller-size inserts, and other nonstandard page dimensions within the same document. 
(Page 12)

Part 5: Manage page items with more control using the all-new Layers panel—Expand top-level 
layers to reveal a sublayer for each object, similar to functionality in Photoshop® and Illustrator® 
software. (Page 13)

Part 6: Format text to span across or split into columns on the fly—Reduce frame clutter and 
streamline layout tasks with these two oft-requested paragraph-formatting features. (Page 16)

Part 7: Manage text edits with Track Changes—Enable the new Track Changes feature in any 
InDesign story to identify each user’s added, deleted, or revised text. (Page 18) 

Part 8: Speed up production by exporting PDF in the background—Export static PDF files 
without interrupting production tasks. (Page 20)

Interactive documents and presentations
Part 9: Animate objects on the page without writing code—Use the new Animation panel to 
apply motion presets and customize settings; preview the results before exporting to SWF. (Page 20)

Part 10: Create multi-state objects that respond to reader’s actions—Make any image, text 
frame, or other object or group appear, hide, or change its look in response to clicks and rollovers. 
(Page 24)

Part 11: Manage FLV and MP3 files with the Media panel—Preview and place FLV files, choose 
poster images and video controller skins, and set time-code markers so that button actions can 
navigate to specific points in a video. (Page 26)

Part 12: Export to SWF—Complete this project by exporting it as a SWF file for playback in Adobe 
Flash® Player. (Page 28)

Before you begin
Please do the following before starting this tour:

•	 Insert the Adobe Creative Suite 5 Master Collection DVD (Disc 1), launch the Setup file, and 
perform a Typical Install. This ensures that the software is configured correctly for this Reviewer’s 
Guide. (Contact Adobe PR for this DVD if you do not already have it.)

•	 To gain the full experience of this tour, make sure your computer is connected to the 
Internet throughout.

•	 Download InDesign_CS5_RG_Assets.zip from the press website at www.adobe.com/aboutadobe/
pressroom/cs5. After downloading, extract the contents of the file to your local hard drive. This 
results in a folder named InDesign_CS5_RG_Assets, which includes the files you’ll need to 
complete the exercises in this guide.

•	 If you have previously installed and worked with InDesign, you may want to restore all prefer-
ences and default settings before beginning this tour. To do so, launch InDesign CS5 while 
pressing Command+Shift+Option+Control (Mac) or Ctrl+Shift+Alt (Windows®), and then click Yes 
when prompted.

•	 For optimum viewing, increase display quality:

1.	Open the Display Performance dialog box (InDesign > Preferences > Display Performance on 
Mac; Edit > Preferences > Display Performance on Windows).

2.	In the Default View menu, choose High Quality.

3.	In the Adjust View Settings menu, choose High Quality. Make sure all three sliders in the 
dialog box are set all the way to the right.

4.	In the Greek Type Below field, type 4, and then click OK.

Top new features
• �Interactive documents and 

presentations (Page 20)

• �Streamlined object selection and 
editing (Page 5)

• Integration with CS Review* (Page 20)

• Mini Bridge panel (Page 3)

• Multiple page sizes (Page 12)

• Track text changes (Page 18)

• �Paragraphs that span and split 
columns (Page 16)

• All-new Layers panel (Page 13)

• Multi-threading support (Page 20)

• Print to digital (Page 28)

• Live captions (Page 10)

*CS Live online services are complimentary for a limited time. See the last page of this document for details and limitations.
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5.	In the View > Extras menu, look for the toggle command Show/Hide Frame Edges. If the 
command says Hide Frame Edges, you don’t need to do anything further. If it says Show 
Frame Edges, choose the command.

•	 Prepare to work on the example projects during this tour. In the InDesign_CS5_RG_Assets folder 
you extracted earlier, locate and open the files called Local_Mag.indd (in the Local_Magazine 
folder) and City_Guide.indd (in the City_Guide folder). 

•	 If you see an alert about a color profile mismatch, choose Leave Document As Is, and then 
click OK.

•	 If you see an alert that links have been modified, choose Update Links. 

•	 If you see an alert that links are missing, click OK to open the document. Then, open the Links 
panel (Window > Links), select the first entry that has a question mark icon , and choose 
Relink from the Links panel menu. In the Locate dialog box that opens, navigate to the Links 
folder that is in the same parent folder as the active document. Browse the contents of that 
Links folder, select the missing file indicated in the Locate dialog box title bar, and then click 
Open. InDesign automatically links to other missing files that are in the same folder. You can 
close the Links panel when you’re done.

•	 Macintosh users: Please open the Window menu and check the status of the Application Frame. If 
the Application Frame menu item is unchecked (off), select it to enable the Application Frame, 
and then click the green (maximize) button at the upper left corner of your application window.

•	 Choose Window > Workspace > Advanced, and then choose Window > Workspace > Reset 
Advanced to ensure the panels in this workspace are at their default settings.

•	 Save working copies of the two layouts:

1.	Choose File > Save As for the active document to open the Save As dialog box. 

2.	Navigate to the appropriate project folder (City_Guide or Local_Magazine) within the 
InDesign_CS5_RG_Assets folder so your file will be saved within it.

3.	Change the filename by adding “My_” in front of the original filename. (For example, save 
Local_Mag.indd as My_Local_Mag.indd, and then click Save.) 

4.	Do the same for the City_Guide.indd document. Use the files that begin with “My_” as your 
working files throughout this tour. Keep the original INDD files around in case you want to 
start over.

FIRST PROJECT: 
Develop and hand off a finished print project file
Building on a strong foundation of integrated tools and workflows, InDesign CS5 introduces new 
features that increase the flexibility, speed, and ease of use. During this first project, you’ll explore 
many of the new production and collaboration features as you put the finishing touches on the 
print version of My_Local_Mag.indd. 

Part 1: Access project assets easily through the Mini Bridge panel
With Adobe Mini Bridge, a new panel in InDesign CS5, you can quickly navigate through the files 
and folders on your hard drive to find and drag images, text files, and other assets into your open 
InDesign CS5 documents—all without leaving InDesign. Mini Bridge also tracks which assets have 
been placed in other InDesign documents, offering a convenient way to quickly reuse linked files in 
a new layout. 

Try it: Drag and drop images from the Mini Bridge panel into the layout
1.	 Click the document tab for My_Local_Mag.indd to bring it to the front.

2.	 Scroll to pages 12–13, or double-click the pages’ thumbnails in the Pages panel to quickly 
jump there.

3.	 Choose View > Fit Spread In Window to center the spread in the window. 

Deliver innovative ideas across 
multiple media

Extend the reach of your designs 
from print to web, interactive, and 
mobile media.

And get more creative power at 
an appealing price. In addition 
to InDesign, Adobe CS5 Design 
Premium combines the latest 
versions of Photoshop Extended, 
Illustrator, Flash Catalyst™, Flash 
Professional, Dreamweaver®, 	
Fireworks®, and Acrobat® Pro—so 
that you can:

Add impact to your layouts with 
expressive images and eye-catching 
graphics. Use industry-standard 
creative tools in Photoshop and 
Illustrator to craft content that 
enhances layouts for print, web, 
interactive, or mobile design.

Repurpose InDesign content 
for web, interactive, and eBook 
projects. Make InDesign content the 
foundation for a web project. Take 
advantage of tight integration with 
Dreamweaver, or export your page 
layout to Flash Professional. Create 
an eBook that can be read on a vari-
ety of eBook devices.

Dive into interactive design without 
writing code. Use brand new Flash 
Catalyst CS5 software to transform 
artwork created in Photoshop and 
Illustrator into attention-getting inter-
active content viewable in Flash Player.

For more information, see Adobe 
Creative Suite 5 Design Premium 
What’s New.

NOTE: You don’t need to open the 
file named New_Spread.indd that is 
inside the Local_Magazine folder. It 
is used indirectly (as a source file) in 
one of the exercises later in this guide.
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This spread is missing its photos. 

4.	 Choose Reveal In Mini Bridge from the Status pop-up menu at the bottom of the window. 

The Mini Bridge panel opens and, because you chose the Reveal In Mini Bridge command, 
automatically navigates to the folder containing the active layout, and selects it in the panel’s 
Content pane. This new panel provides a subset of the same interface and features as Adobe Bridge 
CS5, but in a more compact form.

The Preview pane shows a close-up view of selected assets. 
Either panel can be resized or even closed to afford more 
room to the other pane(s).

Use the Navigation pane to quickly locate folders and files on 
your hard drive or any connected device or server. 

Drag the lower right corner to resize the panel.

The Content pane shows thumbnails of  the selected folder’s 
contents. Link icons on InDesign thumbnails indicate there 
are assets linked to the file, which can be revealed in Mini 
Bridge. Click and drag file thumbnails onto the layout to 
place them in the document. You can also select, filter, sort, 
and run installed actions on selected assets from the widgets 
at the top of the panel, and resize the thumbnails and choose 
slide-show options from widgets at the bottom.

Widgets at the top of the Mini Bridge panel provide 
navigation, viewing, and search functions. Underneath, the 
Path bar lets you intuitively move up and down the folder 
hierarchy to locate and reveal files.

In this scenario, you know that the pictures you want add to the magazine layout were used in the 
other InDesign document in this folder, New_spread.indd. In the Mini Bridge content pane, note 
that the two InDesign files (My_Local_Mag.indd and New_spread.indd) each carry a small link 
icon  indicating that other files are linked to (have been placed in) each layout. Mini Bridge 
provides a visual way to locate files previously used in existing InDesign documents without 
having to search by filenames or remember where they are stored on your hard drive.

5.	 Right-click anywhere on the New_spread.indd thumbnail, and choose Show Linked Files from 
the context menu.

Better media management with 
Adobe Bridge CS5

Whether you are a designer, photog-
rapher, or cross-media creative, 
you can now manage your content 
more efficiently with these new or 
enhanced features in Bridge CS5:
•	The ability to browse linked files in 

InDesign documents

•	 Easy placement of Illustrator files 
from Bridge CS5 or Mini Bridge into 
InDesign layouts

•	 Support for drag-and-drop actions 
between Bridge CS5 or Mini Bridge 
and InDesign

•	 Faster navigation between open 
folders with an improved Path bar

•	 Flexible batch renaming, including 
savable presets of regularly used 
settings

•	Advanced text- and image-based 
watermark options when 
outputting PDF documents

•	 File conversion to JPEG format for 
an easy way to share files via 
websites and galleries

•	 Precise adjustment of the size and 
quality of images in the Web Gallery

•	A Publish panel with simple options 
to output files to disc and upload 
images to popular sharing sites
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Mini Bridge displays thumbnails of all the assets linked to the New_spread.indd file in the Content 
pane, even if the assets are located in different folders. 

Mini Bridge creates a temporary 
collection (circled) that contains 
pointers to all the linked assets in 
their original locations. Dragging any 
of these thumbnails onto a layout 
creates a link to the native file in its 
current location on your hard drive.

6.	 Drag and drop the thumbnail for the image named market2.psd (the fruit market) onto the 
empty image frame on page 13.

If you look in the Links panel, you’ll see that InDesign is linking to the original image in the 
Incoming folder, just as though you had imported it via the File > Place command. Dragging and 
dropping from Mini Bridge is equivalent to dragging and dropping from Bridge itself, except you 
don’t need to leave InDesign to do so.

Part 2: Streamline object selection and editing
Arranging and modifying layout frames is one of the most common tasks for any publication 
designer. With InDesign CS5, those tasks are simpler and easier than ever. You can use one tool to 
select, align, distribute, rotate, resize, reposition, crop, and scale frames and frame content. Live 
Corner Effects and dynamic frame-grid generation make grid-based layouts a snap. The 
breakthrough new Gap tool lets you adjust white space—the gap between frames—while the page 
items maintain their design relationships.  

Try it: Use the Selection tool to modify image content
1.	 Go to page 13 in My_Local_Mag.indd (if you’re not there already), and then choose View > Fit 

Page In Window to center it in the window. 

2.	 Choose Edit > Deselect All.

3.	 Select the Selection tool  from the Tools panel.

4.	 Move your cursor over the fruit-market image. The doughnut shape that appears in the middle 
of the image is called the Content Grabber. When you put your cursor over the Content 
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Grabber, it turns into the Grabber Hand, indicating you can “grab” the image content and drag it 
around to adjust its crop within the frame.

.

In InDesign CS5, you can adjust the position of 
an image within its frame without having to 
select it. Just position your cursor over the 
image with the Selection tool and drag the 
Content Grabber in the center of the image. 
The image, but not the frame, goes along for 
the ride.

Image frames in a group each get their own 
Content Grabber, making it easy to reposition a 
particular frame’s content without having to 
ungroup it first.

5.	 Drag the Content Grabber upwards a bit to show more of the fruit stand and less of the building 
behind it. Release the mouse button when you’re satisfied with the positioning.

Note that as soon as you begin to drag, InDesign shows you the entire image, including the area 
that’s cropped out. Instant crop previews eliminate the need to “press and wait” before seeing the 
content appear. 

If you simply click the Content Grabber (instead of drag it), the image’s bounding box appears. Now 
you can drag anywhere on the image to reposition it in its frame—again, without switching tools. 
Click outside the bounding box to deselect it.

Custom shapes on the fly with Live Corner Effects
With InDesign CS5, you can curve one or more corners of a frame just by dragging on the corner 
itself. All the other special corner effects, like Fancy and Beveled, can be applied in real time as well.

Try it: Curve the corners of an image frame
1.	 Still on page 13, choose View > Fit Page In Window.

2.	 Click anywhere on the image (but not directly on the Content Grabber widget) with the 
Selection tool to select it. 

Note that in addition to the usual resizing handles that appear when you select a frame, a larger 
yellow handle now appears at the upper right of the frame. The yellow handle is specifically for the 
Live Corner Effects feature, and all rectangular frames—text and image—display one when selected. 

3.	 Click the square yellow handle. The resize handles disappear, and each corner of the selected 
frame gains its own diamond-shaped yellow handle. The frame is now in corner editing mode. 

4.	 Drag any one of the yellow handles toward the center of the frame to curve all four corners the 
same amount simultaneously. A curved corner is the default corner effect. 

All rectangular frames show a square yellow Live Corner Effect handle when they’re selected (left). Click the yellow 
square to put the frame into corner editing mode (middle). Drag any of the yellow diamond-shaped corner handles 
to change the shape of the corner (right).

5.	 Option/Alt-click any yellow handle to cycle through the other 
built-in corner shapes. Alternatively, you can choose the shape  
you’d like from the pull-down menu in the Control panel. (It only 
appears when a frame is in corner editing mode.)

6.	 Continue Option/Alt-clicking to return to the curved corner shape.

New double-click behavior

Double-clicking on an image with 
the Selection tool no longer toggles 
between the Selection and the Direct 
Selection tool; instead, the Selection 
tool remains active. 

However, double-clicking does 
toggle the selection between the 
object frame and its content. When 
the frame content—the image—is 
selected, you can transform it with-
out affecting the frame itself, just as 
though you had selected it with the 
Direct Selection tool.

Similarly, double-clicking with the 
Direct Selection tool on an image 
doesn’t change the tool, just the 
selection—either the image itself 
or the frame itself. When the frame 
itself is selected, you can use the 
Direct Selection tool to edit its corner 
and curve points, as usual.
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By default, all four corners change shape in unison as you drag any handle. To limit the editing to 
just the corner you’re dragging, hold down the Shift key.

7.	 Hold down the Shift key as you drag the upper left yellow handle to the left to remove the 
curve, changing it back to a corner. 

8.	 Shift-drag the lower right handle to the right to recreate the lower right corner as well.

It’s easy to create interesting frame 
shapes with the new functionality 
of Live Corner Effects.

9.	 Click anywhere on the page to leave corner editing mode.

Earlier versions of InDesign had corner effects, but the new on-object controls make it much 
quicker to design interesting corner effects directly in the layout.

Easier frame rotation
When you want to rotate a selection by dragging, you can do so simply and intuitively with the 
Selection tool. 

Try it: Rotate with the Selection tool
1.	 Click the Selection tool anywhere on the fruit-market image (outside of the Content Grabber) 

to select it.  

2.	 Move your cursor a little outside of any corner handle until the Rotate cursor  appears.

3.	 Drag to rotate the image.

Performing repetitive and common tasks like cropping and rotating images is easier in InDesign 
CS5 because you no longer have to switch away from the Selection tool. Since there is less of a 
need for the dedicated transformation tools, they are now hidden under the Free Transform tool in 
the Tools panel.

New grid mode for frame creation tools
Many page designs call for a grid arrangement. Creating these on the fly requires just a few taps on 
the arrow keys on the keyboard.

Try it: Create an image placeholder grid
1.	 Go to page 12, and choose View > Fit Page In Window to center it in the window.

2.	 Select the Rectangle Frame tool , and position the cursor at the left margin, just below the 
body text at the horizontal ruler guide.

3.	 Begin creating a large frame by dragging down and to the right.

4.	 When your cursor is roughly halfway across the page, near the center column guides, keep the 
mouse button down and, with your other hand, tap once on the Up Arrow key and then once 
on the Right Arrow key on your keyboard. 

Pressing the arrow keys while dragging out any of the frame tools—including the Text frame 
tool—automatically splits the frame into a grid of smaller frames. Each tap of the Up or Down 
Arrow key adds or removes a grid column; each tap of the Right or Left Arrow key adds or removes 
a grid row. If the page contains column guides, the space between frames is the same as the 
column’s gutter width. 
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5.	 Continue dragging until the cursor reaches the intersection of the right margin guide and the 
bottom horizontal ruler guide, and then release the mouse button. You now have four image 
frames arranged in a perfect grid, ready for artwork.

6.	 Choose Edit > Undo to delete the four empty frames.

Alternatively, you can use the enhanced grid feature for easy placement of multiple images loaded 
into a Place cursor as you drag out an area to place them in all at once.

Try it: Create an image grid from a loaded Place cursor
1.	 Go to page 12, and choose View > Fit Page In Window to center it in the window.

2.	 In the Mini Bridge Content pane (see page 4), Command-click (Mac) or Ctrl-click (Windows) to 
select the four images you haven’t placed yet, and drag the selection onto page 12. 

3.	 Release the mouse button. InDesign loads the cursor with the four image thumbnails.

4.	 Position the cursor at the same starting location as before (on the left margin, just below the 
body text).

5.	 Begin dragging down and to the right.

6.	 Keep the mouse button down as you tap once on the Up Arrow key and once on the Right 
Arrow key to create a grid of four image frames again, and then continue dragging.

7.	 Release the mouse button at the same point as before. The images are automatically placed 
within the four image frames. Each one is scaled proportionately to fit inside its frame.

8.	 Leaving the frames selected, choose Object > Fitting > Frame Fitting Options.

9.	 Choose Fill Frame Proportionately from the Fitting menu in the Frame Fitting Options dialog 
box, click the center dot in the Align From grid ( ), and then click OK.

Dragging out a grid (left) with a loaded cursor and releasing the mouse button results in InDesign placing 
each of the images into the image frames (middle). Leaving the frames selected, change the Frame Fitting 
options to Fill Frame Proportionately and Align From Center to achieve the results on the right.

You won’t be using the Mini Bridge panel again in this guide, so you can close it.

Easier scaling with AutoFit
As in earlier versions, you can still scale an image as you resize its frame with the Selection tool by 
holding down the Command/Ctrl key as you drag a frame handle, adding the Shift key to keep the 
scaling proportional. 

But InDesign CS5 offers an even easier way to scale frame content as you resize the frame, while 
also preserving the chosen Frame Fitting options assigned to the frame. It’s a new fitting option 

Super Step And Repeat using the 
grid mode

As you Option/Alt-drag a page 
element to duplicate it, you can 
release the Option or Alt key and use 
the arrow keys to create multiple and 
equally-spaced duplicates in columns 
and/or rows. Just remember to keep 
the mouse button down as you drag 
and change from Option/Alt to the 
arrow keys.



9Adobe InDesign CS5 Reviewer’s Guide

called Auto-Fit, available in the Frame Fitting Options dialog box 
(Object > Fitting > Frame Fitting Options) and in the Control panel 
(right below the Fitting Options icons that now appear when an 
image is selected).

When an image frame is set to Auto-Fit, as you resize the frame, the image automatically scales 
according to the frame’s Frame Fitting options. There is no need to hold down the Command/Ctrl 
or Shift keys while doing so, or to switch to the Scale or Free Transform tools. 

Try it: Use Auto-Fit to scale an image 
1.	 Still on page 12, choose Edit > Deselect All.

2.	 Click with the Selection tool on the picture of the berries to select it. Since you want to select 
the frame as well as the image, don’t click directly on the Content Grabber.

3.	 Holding down the Shift key, drag the frame’s top right handle down and to the left to resize the 
frame proportionately smaller. Since you haven’t applied Auto-Fit to this frame, the image itself 
doesn’t scale automatically. The smaller frame simply crops out more of the picture.

4.	 Choose Undo from the Edit menu to return the frame to its original size.

5.	 With the berries image still selected, click the Auto-Fit option in the Control panel to turn it on.

6.	 Shift-drag the same corner handle down and to the left to resize the frame proportionately 
smaller. Now the image scales as well, maintaining the same crop. 

7.	 Choose Edit > Undo to the return the image to its starting size. Auto-Fit is still applied.

8.	 Select the other three images on page 12, and then select the Auto-Fit option in the Control 
panel in preparation for the next exercise.

Dynamic white space between page items with the Gap tool
Instead of clicking and dragging on images and frame edges to customize grid designs, just use the 
new Gap tool. It makes it easy to either expand or contract the white space between page items, or 
keep the space consistent while resizing frames to maintain design relationships. 

Try it: Use the Gap tool to modify image alignment and spacing

1.	 Still on page 12, choose View > Fit Page In Window to center it in the window.

2.	 Select the Grid tool , and then position your cursor over the vertical gap between the top 
two images.  

When the Gap tool detects a 
gap between two items on a 
page, the gap it detects gets a 
light gray overlay, and the 
cursor changes to show the 
width of the gap. 
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3.	 Drag to the right about an inch. As you drag, you see a live preview of how the images resize or 
recrop while maintaining the same white-space aspect between images. 

Since all of these image frames were set to Auto-Fit and Fill Frame Proportionately, they scale 
proportionately as their frames change dimensions. Note how with one tool, you’ve precisely 
adjusted the arrangement of all four images.

To add some text under the picture of the berries, you can use the Gap tool to increase the white 
space between the berries image and the corn image below it, modifying the frames on either side 
of the gap the same amount.

4.	 Position the Gap tool cursor in the horizontal gap between the two images on the right (the 
berries and the corn). 

5.	 Hold down Shift+Command (Mac) or Ctrl+Shift (Windows), and drag upwards. Release the 
mouse button when the gap is roughly 1/2" to 1” deep.

Holding down the Shift and the 
Command/Ctrl keys as you drag 
with the Gap tool changes two 
default behaviors at once:

•  �The Shift key limits which frames 
are affected by the Gap tool. 
Only the ones nearest the tool 
change, rather than all frames 
congruent with the active gap. 

•  �The Command/Ctrl key changes 
the gap measure instead of 
repositioning it. Drag up or to 
the right to increase it, down or 
to the left to decrease it.

Using the Gap tool to modify the arrangement of objects without losing their alignment is 
extremely useful, and saves you from tedious clicking and dragging multiple frame edges.

Part 3: Generate image captions from metadata
Digital images have carried metadata for years, but until now it was impossible for InDesign to 
automatically extract it and turn it into page content. Starting from a greatly expanded list of 
metadata types that can be viewed in the Links panel and extending to the ability to automatically 
generate static or live captions for images from the metadata you specify, leveraging image 
metadata in InDesign is a powerful way to speed production and minimize data entry errors.

All this can now be achieved with the new Captions feature in InDesign CS5. Before you use it, 
however, you should specify which metadata you want the Caption to generate. 

Discover the hidden features of the 
Gap tool with the Tool Hints panel

As with some other InDesign tools, 
holding down different modifier 
keys changes the way the Gap 
tool behaves. There are so many 
tools, though, it can be difficult to 
remember which key does what with 
which tool!  

Use the new Tool Hints panel in 
InDesign CS5 to learn about (or 
remind yourself of) the basic function 
of each tool and how the modifier 
keys change the tool’s behavior. 

Choose Window > Utilities > Tool 
Hints to open the panel. 
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Try it: Set up the captions
1.	 While still on page 12 of My_Local_Mag.indd, choose Object > Captions > Caption Setup.

The top section of the Caption 
Setup dialog box lets you 
choose from over 60 types of 
metadata to include in each 
caption, and preface or follow 
each instance with custom text.

The bottom section is where you 
specify the formatting of the 
captions when they’re generated.

2.	 Click the minus symbol  at the far right of the Copyright row to prevent that information 
from appearing in the caption, since you want only the Description for now.

3.	 Leave everything else as is, and click OK.

From now on, any time you invoke either the Generate Live Caption or Generate Static Caption 
command, InDesign uses these settings to extract and format metadata in the layout. 

Live Captions
The Generate Live Caption option creates a caption frame that contains metadata placeholders as 
specified in Caption Setup. On the page, you won’t see the actual caption text until the frame 
overlaps (or is grouped with) an image, which triggers it to show that particular image’s metadata. If 
you drag the frame to another image, or replace the current image with a different one, the caption 
frame contents dynamically updates to show the new image’s metadata.  

Try It: Generate a Live Caption 
1.	 With the Selection tool, click the berries image on page 12 of My_Local_Mag.indd.

2.	 Choose Object > Captions > Generate Live Caption.

3.	 Choose View > Zoom In a few times until the caption text is easily readable onscreen. 

4.	 If the caption frame text is “<No intersecting link>,” nudge the frame up a bit so it overlaps the 
berries image. The Description metadata for the image appears in the caption frame. 

Live caption frames don’t recognize 
an image (top) unless it is grouped 
with or slightly overlapping (bottom) 
that image. 

5.	 With the Selection tool, Option/Alt-drag the caption frame downwards to create a copy of it 
below the corn image.

Since this is a Live Caption, the duplicate frame’s content updates to show the metadata associated 
with the new image.  

Of course, you’re not limited to using the Captions feature just for actual captions; after all, any 
metadata can be included in the automatically generated frame. Use the Caption feature to label 
images with the information that’s most useful to your workflow.

Working with static captions

Instead of using a Live Caption that 
maintains a live link to an image’s 
metadata, you might prefer simply 
generating a Static Caption. 

Static Captions use an image’s 
metadata for their initial text, just like 
Live Captions. Unlike Live Captions, 
however, the text in a Static Caption 
is editable in InDesign. Since it’s not 
linked to an image’s metadata, text 
in a Static Caption remains the same 
even if you move it over or near 
another image.

To create a Static Caption, configure 
the Caption Setup dialog box as you 
would for a Live Caption. Then select 
one or more images on a spread and 
choose Object > Captions > Generate 
Static Caption, or right-click on an 
image and choose the command 
from the context menu.

Live Caption text is not editable. If 
you want to change the text, select 
the caption frame, and then choose 
Object > Captions > Convert To 
Static Caption.

When you place an image (File > 
Place), you can have a Static Caption 
generated for it at the same time 
by selecting the Create Static 
Captions option.

With this option enabled, both the 
image and the caption text are 
loaded into the Place cursor for each 
image selected in the Place dialog 
box. The first click or drag places the 
image in the layout; the next click or 
drag places its caption.

Adding metadata to images

The File > File Info dialog box in 
InDesign, Photoshop, and Illustrator 
is the simplest place to add user-
modifiable metadata to the native file 
you’re working on in that program. 
To create and modify the metadata 
of any file that supports it, or to apply 
the same metadata to multiple files 
at once, use the Metadata pane in 
Adobe Bridge. 
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Part 4: Combine different page sizes in one document
InDesign CS5 gives you the freedom to mix page sizes within a single InDesign file. Use the new 
Page tool and its Control panel commands to change the dimensions of selected pages and specify 
how the change affects existing page elements. You might want to use the Page tool to add a 
narrow book spine in the middle of a spread, enlarge a page for a fold-out map, or keep all the 
elements of an identity project—letterhead, business card, and envelope—in a single INDD file. 

Try it: Add a gatefold to the magazine cover with the Page tool
1.	 Open the Pages panel, and then double-click the thumbnail of page 1 to make it active and 

center it in the window. 

2.	 Choose View > Fit Page In Window.

3.	 Choose Layout > Pages > Insert Pages. 

4.	 Enter 1 in the Pages field and 1 in the After Page field, as shown below, and click OK.

An empty page is added to the right of the first page. As with the other pages in this document, its 
default width is 9 inches. You’ll use the Page tool to select the new page and decrease its width for 
the gatefold. 

5.	 Select the Page tool  from the Tools panel.

6.	 Click anywhere on the empty page in Layout view to select it. 

The Page tool is a new type of selection 
tool specifically for targeting pages for 
resizing. Clicking on a page selects it. 
Selected pages are shown with a blue 
overlay (left). 

When pages are selected with the Page 
tool, the Control panel (below) 
changes to let you edit the size of the 
selected page(s) and customize how 
page elements and master page items 
are adjusted. 

7.	 Enter 18p6 in the Width (W:) field in the Control panel, and then press Return or Enter to 
change the size of the gatefold page.

Now the cover spread is ready for you to extend artwork and type onto the gatefold. (You will do 
so in an upcoming section, as part of the new Layers panel exercises.) 

How master pages work with 
multiple page sizes

A document page inherits its page 
size from its master page. The Page 
tool Control panel presents two 
options that assist you in controlling 
how items on the page are affected 
when a page size changes.

Select Enable Layout Adjustment to 
make page items conform to the new 
page size, per the limits already set up 
in the Layout Adjustment dialog box 
(accessible from the Layout menu). 

If you select the Show Master 
Page Overlay option, a shaded box 
appears over the selected page. You 
can drag the edge of the master page 
overlay so that the master page items 
appear in the same relative location, 
even though the page size is different.
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Fideliity to multiple page sizes is also maintained when printing the document or exporting it to 
PDF. Support for multiple page sizes in InDesign CS5 provides a whole new level of flexibility in 
page design. 

Part 5: Organize layout items and groups with the all-new Layers panel
The Layers panel in InDesign CS5 has received a welcome makeover, and now matches the power 
and usefulness of the Layers panel in Adobe Illustrator and Photoshop. Managing elements in 
complex documents is easier because every object now has its own entry in the panel. Quickly 
find, select, lock, hide, re-order, name, and change the stacking order of individual items in the 
panel. You can reveal the hierarchy of objects in a group, and move an item from one group to 
another just by dragging its layer. Buttons and the new multi-state objects (see page 25) have their 
own disclosure triangles that can be expanded to see their contained objects.    

Try it: Make a multiple selection in the Layers panel and transform the selection 
1.	 Go to page 1 (the cover) of My_Local_Mag.indd. Note the empty gatefold panel on the right 

that you created in an earlier exercise (page 12).

2.	 Click on either of the people pictured on the cover to select the Cover_Models.psd image.

3.	 Open the Layers panel by clicking its name in the panel dock or choosing  Window > Layers.

In the redesigned Layers panel, each top-level layer 
has a disclosure triangle. Click the triangle to reveal the 
sublayers that InDesign creates for each object on that 
layer. Drag any layer or sublayer in the Layers panel up 
or down to change its stacking order.

You can quickly identify groups, buttons, and multi-state 
objects on a layer, because they have their own disclosure 
triangle. Click the triangle to reveal the group’s individual 
items, subgroups, and active states. 

When an object is selected in the layout, the selection 
dot for both the object’s layer and its parent layer 
appear filled with the top-level layer’s color.

InDesign assigns generic names to every object’s layer 
as the object is added to the page. Automatically 
assigned names are surrounded by <braces>. You can 
rename any layer to more easily identify the object.

The selection dot to the right of the <Cover_Models.psd> object layer is selected, as is the one to 
the right of the top-level Text layer, because the image is on that layer. 

The cover photograph is actually two images lying directly on top of each other. The one you just 
selected—the models’ silhouette—is directly above the Cover_Background.psd image. 

4.	 In the Layers panel, click the triangle to the left of the bottom layer, Background Art, to reveal 
its contents.   
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5.	 Shift-click the selection dot for the <Cover_Background.psd> sublayer to add it to the selection.

Click the selection dot (circled, left) to the right of a 
sublayer to select that object in the layout. To select more 
than one object, Shift-click each additional object’s 
selection dot in the Layers panel. The dots are the same 
color as their parent layer.

When multiple objects on a spread are selected, only one 
frame is drawn around them all (above), allowing you to 
transform multiple items as though they were grouped.

In the layout, you’ll notice there appears to be only one frame highlighted, even though the Layer 
panel shows two images, Cover_Models.psd and Cover_Background.psd, are selected. Besides the 
fact that the two image frames are the same size and position, the new behavior in InDesign CS5 is 
to draw a single frame around a multiple selection—as though the items were grouped—instead of 
individual frames around each item in the selection. This allows you to transform multiple objects 
at the same time without having to actually group them.  

6.	 Drag the center resize handle on the right side of the multiple selection frame to the right, just 
as you did earlier. 

Both image frames are resized at the same time.  

Try it: Show and hide layers 
1.	 Click the first empty square (the visibility option, also called the Eye icon) to the left of the Text 

Layer > Flap Copy sublayer in the Layers panel, to toggle the visibility on. 

The first column in the Layers panel controls the visibility of 
the objects in the layer or sublayer to the right. 
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A group of text and art objects that promotes the City Guide insert appears on top of the gatefold 
panel. Now you want to increase the width of the narrow red rectangle at the top of the gatefold to 
extend into the gatefold panel.

Try it: Use the Layers panel to work with grouped objects  
1.	 Click with the Selection tool on the tall red rectangle to the right of the LOCAL masthead. 

Since it’s grouped with the masthead, it’s difficult to select the rectangle individually. Note that in 
the Layers panel, the Text layer and the Masthead sublayer are now selected, so you know the 
rectangle is part of the Masthead group. Since every object in a group now has its own sublayer in 
the Layers panel, it’s much easier to select the exact object you want.

2.	 If necessary, click the disclosure triangle to the left of the Masthead sublayer to reveal the 
objects that are part of its group. There are two sublayers named <rectangle>. You can identify 
which rectangle an instance is referring to by clicking the selection dot and seeing which shape 
becomes highlighted in the layout.

3.	 Click the selection dot to the right of the first sublayer named <rectangle>.

In the layout, the rectangle to the left of of the masthead is selected, which is not the one you want. 
To make it easier to identify automatically named sublayers, you can give them custom names.

4.	 Click once on the name of the first sublayer, <rectangle>, pause, and then click on it again. This 
makes the sublayer name field editable.

5.	 Change the name of the sublayer to Left Rectangle.

6.	 Use the same method to change the name of the other <rectangle> sublayer to 
Right Rectangle. 

Giving an object layer a meaningful name makes it much easier to locate that object in a busy layout. 

7.	 Click the selection dot for the Right Rectangle sublayer to select just that object in the layout, 
without selecting the other objects it’s grouped with. The rectangle to the right of the masthead 
is selected.

8.	 Drag the right side handle of the selected rectangle in the layout to the right, into the gatefold.

Use the Layers panel to 
help you select and edit 
items that are nested into 
groups in the layout.

Finally, adjust the stacking order of the objects on the cover to give it a more dynamic look.

Try it: Change the stacking order of items by dragging and dropping layers 
1.	 In the Layers panel, drag the <Cover_Models.psd> sublayer up so it’s the first sublayer in the 

Text layer, above the Masthead sublayer. 

The models’ heads overlap the masthead and headline, creating an interesting effect, but now the 
text in the gatefold is almost completely overlapped and hidden by the man’s body.

Use the Escape key to select items 
in groups from the keyboard

When a group is selected in the 
layout, pressing Shift+Escape drills 
down into the group and selects a 
single object or subgroup. Continue 
pressing Shift+Escape to drill down, 
or press Escape to come back up, 
reselecting the parent group(s) with 
each tap of the Escape key.
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2.	 Drag and drop the Flap Copy sublayer until it’s above the <Cover_Models.psd> sublayer and 
therefore no longer obscured by the image.

The completed cover has an interesting 
interplay of overlapping objects. The Layers 
panel makes it easy to adjust the stacking 
order of objects by simply dragging and 
dropping layers and sublayers.

Part 6: Format paragraphs to split or span frame columns on the fly
The new Split Columns paragraph attribute in InDesign CS5 allows you to make one or more 
paragraphs flow into two or more columns within its default single column, easing the creation of 
complex layouts. The new Span Columns paragraph attribute lets you specify that a paragraph 
extend across two or more columns in a multi-column text frame, avoiding the need to tediously 
create, position, and manage an additional frame just for that text.  

Try it: Apply the Split Column attribute to a selection of short paragraphs
1.	 Go to page 10 of the My_Local_Mag.indd document.  

The text on page 10 is contained in a 
single, 3-column text frame.  

The long list of short, bulleted 
paragraphs in the first column results 
in an objectionable amount of empty 
space to its right. There is plenty of 
room for another column of bullets in 
that area.

2.	 With the Type tool, drag through all the bulleted paragraphs in the first column to select them.

3.	 Choose Split 2 from the new Control panel pull-down menu for spanning and splitting columns.

When the Control panel is in 
Paragraph Text Formatting mode, a 
new pull-down menu appears for 
spanning and splitting the columns 
for selected paragraphs. The 
numbers in the menu commands 
indicate the number of columns to 
span or split. 

Balancing columns

You can balance the text in a multi- 
column text frame with a new 
Balance Columns option in the Text 
Frame Options dialog box.

A common example is a short last 
column in a multi-columned frame.

Simply select the frame, and then 
choose Object > Text Frame Options. 
Select Balance Columns in the dialog 
box that appears, and then click OK.

The text in each column in the frame 
adjusts to keep the column depths 
the same—even as you edit the text.

The Balance Columns attribute can 
also be included in an object style.
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The bulleted paragraphs now flow into two columns within the main column. Since it’s a paragraph 
attribute, the split column formatting persists whenever the text flows to a new column or frame, 
even if you change the number of columns in the text frame.

You can use the Span Columns dialog box (which also has the controls for Split Columns) to change 
the width of the inside gutter (the space between split columns), the outside gutter, and the space 
before or after the split. 

Try it: Apply the Span Column attribute to a paragraph
1.	 Click inside the subhead paragraph in the third column of page 10 to target it. (It’s the bold 

paragraph that begins with the word “Cobblestones [...]” and runs onto two lines.)

2.	 Click the Control panel menu button  (at the right edge of the panel) and choose Span 
Columns from the panel menu. The Span Columns dialog box opens.

3.	 Choose Span Columns from the Paragraph Layout menu.

The Span Columns dialog box 
has controls for both spanning 
and splitting columns. Click 
Preview to see the results of 
your settings in the layout 
without closing the dialog box.

4.	 Enter 2 in the Span Columns field so the subhead spans two of the three columns.

5.	 Enter 1p in the Space Before Span field to add one pica of white space above the subhead.

6.	 Click OK to close the dialog box and view the results. 

The text on page 10 looks more 
balanced and readable after 
splitting and spanning the 
columns containing the ill-
fitting paragraphs, and no extra 
text frames were necessary.

Include it in a paragraph style

When you create a new paragraph 
style or edit an existing one, you 
can now include settings for column 
spanning and splitting.

  



18Adobe InDesign CS5 Reviewer’s Guide

Part 7: Manage text edits with Track Changes
Turn on the new Track Changes feature to keep an internal record of text edits in an InDesign 
document. Additions and deletions are tracked on a per-user basis and can be easily viewed within 
the Story Editor window. Use the controls in the new Track Changes panel to accept or reject the 
changes individually, or all those made by a given user, or all changes for the entire story. Using 
Track Changes allows designers to more easily keep track of text edits suggested by writers and 
editors, and avoids paper printouts that include marked-up text changes. 

Try it: Create a username and color for your Track Changes identification
1.	 Choose File > User.

2.	 Replace the default User Name entry, Unknown User Name, with Designer. 

3.	 Choose a color from the Color menu. 

 

In InDesign, user names 
and colors identify the 
author(s) of tracked 
changes and inline 
notes. You can choose 
any user name or color 
you’d like.

You need to set up a username only once after installing the program (or after rebuilding InDesign 
Preferences). It is then used for all InDesign documents thereafter unless you go back and change it 
in the User dialog box.

Try it: Edit text and view the Track Changes markup
1.	 Go to page 10 of the My_Local_Mag.indd file, and then click inside the subhead with the Type tool.

2.	 Open the Track Changes panel from the Window > Editorial submenu.

The Track Changes panel is part of a group of editorial 
workflow panels that includes Assignments (for 
sharing layouts with Adobe InCopy) and Notes. 

Use the buttons along the top of the Track Changes 
panel to turn Track Changes on and off, view/hide 
Track Changes markup, go to previous/next tracked 
changes, and accept or reject tracked changes.

3.	 Click the first button in the panel to turn on Track Changes for the current story. 

4.	 In the subhead, change “local produce” to farmers’ markets.

To see the change being tracked, you’ll need to switch to the Story Editor view. The Layout view 
never shows tracked changes markup, so you don’t need to worry about it accidentally appearing 
in print or PDF output.  

5.	 Choose Edit > Edit In Story Editor.

Added and deleted text is 
highlighted with the color 
associated with the user who 
made the change. A vertical 
blue Change Bar appears to the 
left of every line containing a 
tracked change.
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In Story Editor, your edit is highlighted with your user color. 

6.	 Click an insertion point anywhere inside the markup. The Track Changes panel shows details 
about the active tracked change. 

If you scroll through the story in the Story Editor window, you can see there are edits made by 
another user, because these are highlighted in a different color. The Track Changes feature lets you 
quickly review the changes and accept or reject them.

Try it: Accept tracked changes made by another user 
1.	 Click inside any of the tracked changes made by the other user. You can identify these because 

they’re in a different color, and the Track Changes panel shows a different author’s username.

2.	 Click the Accept Change button  in the Track Changes panel to accept the active change. 

3.	 Click inside another tracked instance of a text edit made by the other user so that the Track 
Changes panel once again shows their name as the author.

4.	 From the Track Changes panel menu , choose Accept All Changes By This User > In This Story.

All of the markup for the other user disappears. What they had deleted is removed from the story 
and what they added remains. Your own tracked changes markup remains visible, however.

5.	 Close the Story Editor window.

Editorial workflow options

Adobe InCopy® CS5 software, the 
editorial complement to InDesign 
CS5, allows writers and editors to 
edit stories within the context of 
the design. The new Track Changes 
feature in InDesign supports round
trip change tracking between the two 
applications. For more information 
on Adobe InCopy CS5, see http://
www.adobe.com/products/incopy.

Another workflow option, new in 
InDesign CS5, is integration with 
Adobe Buzzword®, the online word 
processing and collaboration applica-
tion that’s part of the CS Live online 
service* Acrobat.com.

You can place Buzzword documents 
into an InDesign layout by choosing 	
File > Place From Buzzword.

Formatting applied to the file in 
Buzzword is maintained. You can 
optionally link to the online file, 
so that you are notified when the 
document has changed, and you can 
then update your layout with the 
latest version. 

Designers can also export a story 
(the contents of a text frame) from 
InDesign directly to Buzzword 
by choosing File > Export For > 
Buzzword. Doing so creates a new 
online Buzzword file.

*Acrobat.com and other CS Live online services are complimentary for a limited time. See the last page of this document for details 
and limitations. 
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Part 8: Speed up production by exporting PDF in the background
InDesign now takes advantage of multithreading for processor-intensive operations, such as a 
complex PDF export that requires image downsampling, compression, and color-space conversion. 
Instead of putting everything on hold, the multithreading takes over as soon as InDesign starts to 
export the PDF, allowing you to continue to work on document pages in the layout.

Try it: Test the difference that multithreading makes 
1.	 Choose Window > Utilities > Background Tasks. This new panel reports on multithreaded tasks.

2.	 Choose File > Adobe PDF Presets > [High Quality Print].

3.	 Name the PDF, select a location, such as your desktop, and then click Save. The PDF Export 
dialog box opens.

4.	 Click the Export button in the PDF Export dialog box to accept the default settings for this PDF 
export preset.

5.	 If you get any alerts about overset text or missing or modified links, just click OK to continue 
with the export.

When InDesign begins the export, notice that you don’t see a progress bar dialog box that 
temporarily takes over the program’s operations, as in previous versions. Instead, you are 
immediately able to continue working on this document or any other one in InDesign. 

The new Background Tasks panel reports on the progress of the PDF export process.

The new Background Tasks panel gives you 
real-time feedback on the progress of 
InDesign operations being handled by one 
of the multiple processors of your computer. 

Click the Cancel button (the X) to the right 
of any task appearing here to quickly and 
safely interrupt the operation.

If any system-related problems occur during 
the process (such as your computer is out of 
memory and can’t complete the export), 
they’ll be reported in the Alerts section at 
the bottom of the panel. 

Now you can maximize your production time by exporting PDF documents in the background as 
you continue to work. This is especially relevant when exporting very large PDF files from InDesign.

You’re done working with My_Local_Mag.indd for now. You can close the file, saving changes if 
you like. (Remember, you can always start from scratch by opening up the original Local_Mag.indd 
file from your assets folder.) 

SECOND PROJECT: 
Create interactive documents and presentations
You can engage and inform readers and clients with documents and presentations that integrate 
interactivity, animation, sound, and video. Add rich media to your page layouts directly in InDesign 
using a new set of intuitive tools, motion presets for easy animation creation, and support for 
import of FLV, F4V, and MP3 audio files. As you add movies, sounds, buttons, and animation to 
your layouts, you can test their functionality and preview end results without exporting your file to 
SWF, saving you time and resources.

Part 9: Animate objects on the page without writing code
Use animation to visually illustrate editorial concepts in new and informative ways. In the SWF file 
you’ll be exporting from InDesign, do you want a graphic to fly in to your digital layout from the 
right? A headline to scale up to 300%? Page icons to bounce up and down when the user clicks 

* CS Review and other CS Live online services are complimentary for a limited time. See the last page of this document for details 
and limitations. 

Share documents for online 
commenting with Adobe CS Review*

Streamline reviews and accelerate 
the design workflow with CS Review, 
a new Adobe CS Live online 
service*. Integration with CS Review 
allows you to create and share 
documents for online review from 
within InDesign. 

Colleagues and clients can view 
your document online and add 
comments with easy-to-use annota-
tion tools directly in their browsers. 
All comments are automatically 
displayed in InDesign CS5, within 
the context of your page layout. 
Selecting a comment takes you to 
the content it references, so you can 
easily match comments to the appro-
priate areas of page design. 

Simple sharing, easy access to 
reviews, and centralized comments 
help speed up the review process so 
that you finish your project on time 
and within budget.
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them? All this and more can be done right in InDesign CS5 using the new Animation panel and 
motion presets. Any object you can select with the Selection tool can be animated, and a single 
page can have multiple animations occurring at the same time. You can manage the order in which 
animations appear with the new Timing panel.

Try it: Animate an object and preview the animation in InDesign
1.	 Open the file My_City_Guide.indd, and go to page 6.

2.	 Choose Window > Workspace > [Interactive], and then choose Window > Workspace > Reset  
Interactive to ensure the panels in the panel dock are at their default settings. The Interactive 
workspace populates the panel dock with all of the panels you’ll use in this section.

3.	 Click the heading labelled LIVE with the Selection tool.

4.	 Click the Animation panel in the panel dock to expand it. 

This area shows a placeholder 
preview of the animation using 
the settings chosen below.

Name the animation and 
choose a motion preset.

Choose the event that will 
cause the animation to play, 
and configure the settings for 
the animation’s duration, 
speed, and other properties.

From left to right, these icons are: 
Preview panel, Show/Hide Proxy, 
Timing panel, Convert To Motion 
Path, and Delete Animation.

In the Animation panel, InDesign 
automatically assigns a name to 
objects you work with, such as the 
name “group” for the selected LIVE 
headline. They are easier to keep 
track of and reference elsewhere if 
you replace the automatically 
generated name with a custom one.

5.	 Click inside the Name field, and change the name of the selected object’s animation from 
“group” to LIVE headline.

6.	 Choose Fly In From Top from the Preset menu. 

The motion path placeholder animation (a pink butterfly) appears in the top part of the Animation 
panel, fading in as it drops down from the top, just as the animated object will do in the final 
exported SWF file. The animation’s opacity and other settings can be viewed and modified by 
revealing the Properties section in the panel. 

A green motion path appears behind the LIVE headline, showing the starting point (a green dot in 
the pasteboard) and ending point (a green arrow in the layout) of the path the object will take.

The green motion 
path created when 
you choose certain 
presets is editable 
with the Direct 
Selection or the Pen 
tool. Click the path 
to put it into editing 
mode first.

Animation frame adornment

In Normal view when Frame Edges 
are showing, any object that is part 
of an animation will carry a semi-
opaque animation adornment ( ) 
in its lower right corner, helping you 
to quickly identify animated items.

Borrowing from Flash Professional

The choices that appear in the Preset 
menu in the Animation panel are all 
motion presets—the same kind that 
are included in Flash Professional. 
Since they are the same format, 
InDesign and Flash users can collab-
orate to create animation effects 
that go beyond those provided out 
of the box. 

To share custom presets between 
InDesign and Flash Professional, 
choose Manage Presets from the 
Animation panel menu,  and then 
click the Load and Save As buttons to 
import and export motion presets.
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You can change the animation’s duration, speed, and other settings in the panel. To see the actual 
page animation—to see LIVE drop down into the layout—without having to export the file to SWF, 
you can use the new Preview panel. It saves you a significant amount of time by letting you preview 
and test interactive features in InDesign.

7.	 Click the Preview Spread button  at the bottom left of the Animation panel, which opens the 
Preview panel and automatically generates a preview of the active spread and its animations. 
You may want to drag the panel’s grow box (the lower right corner) to enlarge the panel, 
showing you a larger preview of the spread. 

The new Preview panel 
plays all the animations in 
the active spread using the 
same settings they’ll have 
in the final SWF. Buttons at 
the bottom of the panel let 
you start and stop 
animations, view other 
spreads, preview just a 
selected animation, or 
preview all the animations 
and interactivity in an 
entire document. 

As you can see from the preview, this spread has a few other animations. The text “YOU DON’T 
POCKET MULCH?” uses a different built-in motion path, and the flies buzzing around the handful of 
mulch are traveling around their own custom paths in a looping animation.

InDesign allows you to create motion paths from custom artwork created in InDesign or Illustrator. 
Converting artwork to a custom motion path is as simple as clicking a button.

Try it: Animate an object along a custom motion path
1.	 Click the LIVE object in the layout to select it. (If necessary, close or dock the Preview panel to 

get it out of the way for now.)

Click the Delete Animation button  at the bottom of the Animation panel. The animation you 
just applied to the LIVE headline is removed, but the object remains in the layout as before, and 
is still selected. (This step is necessary because an object can have only one animation applied.)

2.	 Shift-click the black vector path in the pasteboard to the left of the LIVE headline to add it to 
the selection.

This is a simple vector path that you will convert to a motion path. 

3.	 Click the Convert To Motion Path button  at the bottom right of the Animation panel. 

The vector path turns green, indicating that it’s now a motion path. It joins to the object, and 
repositions itself so the top of the path is aligned with the object’s center. The arrow at the bottom 
of the path indicates the final position of the object when the animation ends.  

Animations in a PDF?

Animation features are supported 
only when exporting to SWF files 
for playback in Adobe Flash Player. 
They are not directly supported when 
exporting to an interactive PDF. 

To add animation effects to a PDF 
file, select the animation, and export 
the selection (a new feature in 
InDesign CS5) as a SWF file from 
InDesign. Then place that SWF file 
in the InDesign document instead 
of the original animation. (Move the 
original animation to the pasteboard 
so that you can edit it and re-export 
if necessary.) 

When you export the layout 
to Interactive PDF (File > 
Export >  Format: Interactive PDF), 
the animation appears.
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4.	 Drag the LIVE animation object up so that the end of the motion path—the green arrow—is 
roughly centered in the empty area at the upper left corner of the spread. 

Drag the LIVE object from its current position (left) upwards, until it’s above the spread in the pasteboard (right). 
You’re positioning it so that the end of the motion path, represented by the arrow, is where you want the center of 
the animated object to move to.

5.	 Click the Preview Spread button at the bottom of the Animation panel to preview your work. 

After the preview plays, you can see the animation is working, but one problem remains: The LIVE 
headline should animate as soon as the user loads the page. However, according to Preview, it 
doesn’t begin until the other animation (the Pocket Mulch text frame) is complete. That’s because 
animations appear on the spread in the order they were created. 

You can control animation timing and playback in InDesign CS5 without having to use a timeline to 
add keyframes or manage motion tweening. The new Timing panel gives you unprecedented 
power over complex multiple animations with easy-to-understand controls.

Try it: Use the Timing panel to change when an animation occurs
1.	 Choose Edit > Deselect All.

2.	 Click the Timing panel in the panel dock to open it, or choose Window > Interactive > Timing. 
All the animations for the active spread are listed in the Timing panel.

The Timing panel lists all animations 
on a page that will play when the 
page is loaded (the default event for 
animations) or when the page 
is clicked.  

Animations play in the order their 
names appear in the panel. Select an 
animation’s name and drag it up or 
down in the list to change when it 
plays in relation to the others.

You can also choose to have two or 
more animations play simultaneously 
by selecting them and clicking the 
Play Together button  at the 
bottom of the panel. The animations 
are then linked, as the first four 
animations in this panel are. 

The Preview Spread button  at the 
bottom left of the panel (as in the 
Animation panel) lets you quickly 
preview the results of your Timing 
edits in the Preview panel.
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3.	 Select the LIVE headline entry, and drag it upwards. As you 
drag, a heavy horizontal line indicates the entry’s position. 

4.	 Release the mouse when the line is above the entry for Fly 1. 
The LIVE headline entry now appears at the top of the panel 
(as shown at right). 

5.	 Click the Preview Spread button.

When the modified spread loads and plays in the Preview panel, you can see that the LIVE headline 
animation plays first. After the LIVE object comes to a stop in its final position, the Mulch Sign 
animation starts, and the flies start buzzing around the handful of mulch. 

6.	 Click the LIVE headline entry in the Timing panel to select it.

7.	 Shift-click the last animation’s entry, Mulch Sign, so that all the animation names are selected.

8.	 Click the Play Together button  at the bottom right of the 
panel. Doing so adds the LIVE headline to the existing linked 
group of animations, which you can see by the line connect-
ing all the animation names in the panel. 

9.	 Click the Preview Spread button again.

Now all the animations play simultaneously. As the LIVE 
headline winds its way onto the page, the Mulch Sign reveals 
itself, and the flies start buzzing around. 

10.	Collapse the Preview panel and the Timing panel back into the panel dock.

By working with the powerful Animation and Timing panels, and frequently checking the Preview 
panel, you can create amazing, entertaining, and innovative effects in the final interactive SWF file 
without writing a single line of code or working in a timeline.

Part 10: Create multi-state objects that respond to reader’s actions
InDesign CS5 introduces a new kind of page item: a multi-state object. It’s an object that changes 
its content when a user clicks a button in a SWF file. Using the new Object States panel, a layout 
item can be defined as a multi-state object that displays, for example, different images in a slide 
show or versions of text in different languages. 

Try it: Create a multi-state object to use as an image slide show
1.	 If necessary, open the My_City_Guide.indd document, and go to page 6, the LIVE spread.

2.	 Click the image of the building corner on the right side of the page to select it. 

3.	 Open the Layers panel, and locate the object sublayer for the selected image (in the High Art 
top-level layer).

As you can see from the Layers panel, there are four additional pictures of buildings directly 
beneath the one you selected. 

4.	 Shift-click the selection dots for the four other images listed underneath the selected image in 
the Layers panel.

Use the new Layers panel to make multiple 
selections of items that are tricky to select in 
the layout. Clicking an object layer’s 
selection dot selects the object in the layout.

To add to the selection, hold down the Shift 
key, and click the selection dots for the other 
objects (in this case, the four images below 
the one you selected in the layout). 
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Now that all the images are selected, you can convert them to a single multi-state object. 

5.	 Click the Object States panel in the panel dock to reveal it.

6.	 Click the Convert Selection To Multi-State Object button  at the bottom of the panel to 
convert the selected objects to a single multi-state object.

7.	 Click in the Object Name field, and change the name to Building slideshow.

Use the new Object States panel (left) to convert 
selected objects to a single multi-state object. 

You can edit the multi-state object’s name and the 
name of each individual state directly in the panel. 

The individual objects that used to appear in the 
Layers panel (below) are replaced with an entry 
for the multi-state object and the currently 
selected state.  

In the layout, the page item now has a thick dashed outline (in the same color as the layer it’s on), 
just as though it were an object group. You can preview the object’s multiple states in the layout by 
selecting them one by one in the Object States panel. 

8.	 Choose Edit > Deselect All.

You can create navigation buttons near the slide show to give the end user a way to change the 
different images when they’re viewing the SWF in their browser.

Try it: Create navigation buttons for the Building slideshow 
1.	 Click the right arrow image to select it, on the right side of the Building slideshow on page 6. 

2.	 Open the Buttons panel in your panel dock, or choose Window > Interactive > Buttons.

As you can see, the object has already been set up as an interactive button named “next photo” 
and has Normal, Rollover, and Click states. Although the triggering event is already set (On 
Release), the Actions area is empty—it says [No Actions Added].

3.	 Click inside the Actions area to activate it.

4.	 Click the Add Action button  to open the pull-down menu of available actions. 

5.	 Choose the Go to Next State action in the SWF Only section of the menu.

In the Buttons panel, the Actions 
menu is reorganized to make it clear 
which actions can be used with 
which types of output (either SWF or 
PDF, SWF only, or PDF only). 

New actions in the SWF section 
include Animation (for starting and 
stopping animations on the page) 
and the ones that navigate to 
different states of multi-state objects.

The left and right arrows on either side 
of the Building slideshow above (the 
right one is selected) have already 
been defined as buttons. 
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Since there’s only one multi-state object on this spread, InDesign automatically chooses it in the 
Objects menu  below the Actions area. If you had more than one such object, 
you’d specify which one the button action affects by selecting it in this menu. 

6.	 Click the left arrow artwork, to the left of the Building slideshow in the layout, to select it. Like 
the right arrow, it’s already a button, and just needs the correct action assigned to it.

7.	 In the Buttons panel, click the Add Action button , and choose Go To Previous State from the 
Actions menu. As before, the Building slideshow object should automatically be selected. 

To make sure clicking the buttons actually do navigate through the multiple photos, you could 
export the file to SWF (File > Export) and test it in your browser, but it’s faster to use the Preview panel.

8.	 Click the Preview Spread button  at the bottom of the Buttons panel, or press 
Command+Option+Return (Mac) or Ctrl+Alt+Enter (Windows). You may want to enlarge the 
panel to see the spread better.

9.	 Click the left and right buttons on either side of the slide show to see the photos change. Your 
cursor changes to a pointing finger when it’s over a button, even in the Preview panel.

Multi-state objects open the door to many creative solutions when designing layouts. There is no 
limit to the number of states you can create for a multi-state object, and the states don’t even have 
to be the same type of object. For print projects, you could even use the Object States panel to 
create something close to conditional objects—whichever object is visible (selected in the panel) is 
what gets printed or exported to PDF—without having to create additional layers.

Part 11: Manage FLV and MP3 files with the Media panel
Now you can import the latest video and audio formats, including SWF, FLV, and MP3, into the rich 
media projects you author in InDesign. The new Media panel is your one-stop shop for setting up 
video and audio options—replacing dialog boxes in previous versions. Using the panel, you can 
preview videos, set playback options, choose controller skins, create navigation points (time-code 
markers that can be targeted by a button action), link to external media files, and scrub through 
video to locate the one frame that would make a perfect placeholder poster image.  

By default, video files 
placed in an InDesign layout 
show up with a generic 
filmstrip icon in the upper 
left corner as a placeholder. 
(The video frame has been 
filled with [Black] to make it 
easier for you to identify in 
the file.)
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Try it: Choose a poster image from a frame in the video
1.	 Go to page 11 in the My_City_Guide.indd file, and select the large black video frame at the top 

of the page.

2.	 Click the Media panel in the panel dock to open it, or choose Window > Interactive > Media.

3.	 Drag the slider in the panel to scrub through (preview by dragging) the video.

4.	 Stop dragging when the Media panel is previewing a video frame that you’d like to use as a 
placeholder poster image.

Use the new Media panel to 
preview placed video and 
audio files, choose poster 
images, set looping, assign a 
playback controller, and 
create navigation points that 
buttons can be set to jump to.

Drag the preview slider 
(circled) to scrub through the 
selected video.

5.	 From the Poster menu in the Media panel, choose From Current Frame.  In the layout, the video 
updates to show the same frame as its placeholder image.

After you export the file to SWF or PDF, people will need some way of playing the video, stopping 
it, changing the volume, and so on. The Media panel lists dozens of controller skins you can choose 
from to enable these operations.

Video and audio formats

In addition to FLV, F4V, SWF, and 
MP3 files, InDesign CS5 continues 
to support common media file types 
like MOV, AVI, and WMV. 

Since the latest versions of Acrobat 
Reader and Adobe Flash Player offer 
more features for FLV playback, 
InDesign CS5 ships with the Adobe 
Media Encoder so users can convert 
older video formats to FLV.

TLF: Enhanced text conversion for 
Flash Professional CS5

When you export an InDesign docu-
ment to an editable Flash Pro CS5 file, 
you have a new option for how the 
formatted text is converted.

When specifying options in the 
Export dialog box, choosing Flash TLF 
Text from the Text menu means that 
each text frame in InDesign converts 
to a single text frame in Flash (instead 
of each line getting converted into 
its own text frame), making it much 
easier to edit in Flash. Even threaded 
text frames are maintained!

Also, if Flash doesn’t support a partic-
ular text attribute, using the new TLF 
text engine ensures that the character 
is always converted to editable Flash 
text (instead of being converted to 
artwork), even if its appearance can’t 
be maintained in the Flash file.  

To export a file to editable 
Flash format, choose Flash CS5 
Professional (FLA) from the Format 
menu in the File > Export dialog box.
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Try it: Choose a video controller and preview it
1.	 Make sure the video is still selected in the layout and the Media panel is open.

2.	 Click the Controller pull-down menu in the Media panel and choose SkinOverPlaySeekStop. 

3.	 Click the Show Controller on Rollover checkbox so that when someone viewing the SWF passes 
their cursor over the video, the controllers will show up. 

The Media panel now shows these settings:

4.	 Click the Preview panel in the panel dock to open it, and then resize it larger to better see the 
full spread and movie.

5.	 Click the Play preview button  at the bottom left of the Preview panel. 

After a short wait, the spread appears in the panel. 

6.	 Click the video to make the controller appear, and then click the Play button to preview the movie.

Part 12: Export to SWF
When you export to SWF, you create an interactive file that’s ready for viewing in Adobe Flash 
Player or in a web browser. InDesign CS5 provides an improved and more robust set of SWF export 
options than in previous versions. The SWF file can now include animations, movies, and audio 
files, in addition to buttons, page transitions, and hyperlinks added in InDesign. 

Exporting to SWF is a good way to create an interactive slide show, or a flip book, based on an 
InDesign document.

Try it: Export the document to SWF and view it in a browser
1.	 With My_City_Guide.indd file open, choose File > Export.

2.	 Choose Flash Player (SWF) from the Format menu in the Export dialog box.

3.	 Click Save.

Enhanced print to digital options

Hand off InDesign CS5 pages to Flash 
Professional CS5 with greater fidelity. 
In addition to improved text support 
(see sidebar, page 27), interactive 
buttons, multi-state objects, and 
placed video and audio files included 
in the InDesign CS5 layout are carried 
over into Flash Professional. Objects 
animated with motion presets in 
InDesign are added to the Flash 
Professional timeline as motion 
objects. The original layer structure of 
the InDesign document is recreated 
in the Flash Professional timeline, so 
the Flash developer can easily under-
stand how pages were created.

Create compelling eBooks with 
enhanced support for the EPUB 
file format. When you export a file 
to EPUB, you can control content 
reading order based on document 
structure. Other improvements 
include support for prebuilt CSS to 
provide consistent styling, support 
for chapter breaks, improved table 
formatting, and font subsetting.

Get a head start building web pages 
with enhanced export features that 
let you repurpose InDesign text 
and image content using Adobe 
Dreamweaver CS5 software. Using 
the Structure panel in InDesign, you 
can control the order in which page 
content is placed on the web page 
when imported into Dreamweaver. 
InDesign now generates CSS 
definitions that more closely match 
the text attributes you specify in 
InDesign to give you greater control 
over typography and reduce the 
need to rework text in Dreamweaver.



Before the file is actually exported and saved, the redesigned Export SWF dialog box appears. 

The Export SWF dialog box has been split into two 
sections, General (left) and Advanced (right), to make 
it easier to find the options you want to set. 

Settings that affect the quality and size of the final SWF 
file are in the Advanced section. Move your cursor over 
a setting’s label to see an informative description of the 
trade-offs to consider for the active setting.

4.	 Click OK in either panel, leaving the settings at their default.

After a moment, the final SWF file opens in your default browser. Take some time to enjoy the 
animations and interactivity in the file, and to test the elements you configured yourself.
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Wrapping up
Thank you for taking the time to explore some of the powerful new features and enhancements in 
Adobe InDesign CS5. For additional information, please refer to Adobe InDesign CS5 What’s New, to 
the Reviewer’s Guides for Adobe Flash Professional CS5 and Adobe Creative Suite 5 Design 
Premium, and to the Adobe InCopy CS5 and InDesign CS5 Workflow Guide.
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Adobe is the world’s leading provider of software solutions to create, manage, and deliver high-
impact, reliable digital content. For more information, visit www.adobe.com.

*This product may allow you to extend its functionality by accessing certain features that are hosted online, including CS Live online 
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a separate subscription. For more details and to review the applicable terms of use and Online Privacy Policy, visit www.adobe.com. For 
more information about CS Live online services, see www.adobe.com/go/cslive.
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